Movabletype 3.1 アップグレード

Movabletype 3.1 アップグレードMovabletype 3.1にアップグレードしてみた。大失敗。動くことは動くものの、エラーメッセージ出まくり。アップグレードを指示するcgiを走らせてみると、

You have not yet upgraded to the 3.0 version of MT. Please do that before you run this script. Exiting…

とのメッセージ。NDOWeblogさんによると、

mt-upgrade30.cgi にはバージョンチェックのコードが入っているのですが、単にファイルを上書きしただけだと、ウェブサーバ上では 2.6 のコードがロードされたままになっていてそちらが実行されてしまうのが原因です。ウェブサーバを再起動すればこのエラーを回避することができます。

とのことなので、3.0→3.1でも同じ症状が発生しているんでしょう。ああ、再インストールかなあ。涙が出る。

管理画面の下の方にも「Content-Type: text/html Got an error:」なるエラーが頻繁に表示されるので、もうシステム的に死にかけです。基本機能が動いてはいるので、しばらくは目をつぶってみることにします。

Similar Posts:

カテゴリー: A:Diary パーマリンク

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です